Async server outage

Incident Report for Heron Data

Resolved

Incident has been resolved. Postmortem to follow.

We had an issue where our asynchronous processing capability was compromised by an infinite looping async task from a new feature launch. The root cause is now understood, and a fix is planned. For now the feature is disabled across Heron platform
Posted Jul 16, 2025 - 00:11 UTC

Update

We have remediated the issue and all new submissions will process normally. We are recovering on older submissions that were created during the outage
Posted Jul 15, 2025 - 23:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2025 - 23:47 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 15, 2025 - 23:41 UTC
This incident affected: API (Root, Transactions).